Announcement

Collapse
No announcement yet.

Filling issues!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Filling issues!

    Hi,
    Sorry if this has been coven many a time. But I have an issue with filling my car with Cng. I plug the pump in correctly, but the pump automatically stops after a few cent have gone in.. Once I disconnect the pump from the cars filling valve, the filling valve on the car releases all the gas that has gone in. I'm suspecting a blocked valve? Anyone know of a previous thread that covers the same issue.

    Many thanks in advance!

  • #2
    Check to see if your inlet receptacle has a metal mesh screen. (when looking in the tip. If so, the screen is plugged. Not sure if it is legal but you can remove the mesh with the tip of a screw. Be careful not to scratch the metal of the receptacle, valve ball or damage the oring.

    Comment


    • #3
      Thanks for the response. I cannot see a metal mesh. Looking into the inlet receptacle, it looks as if your looking down a mini step drill bit, with a ball on the top. I believe the fitting is a WEH ngv1 or very similar.

      Comment


      • #4
        the little ball may be stuck try tapping it with a BRASS pin and small hammer just tap lightly also check main emg shut off valve under car

        Comment


        • #5
          Maybe there is a clogged check valve between the fill connector and tank?

          Comment


          • #6
            It can also be failed electronic valves. Someone would need to see if there is power at the tank valves.

            Comment


            • #7
              Hi! Just picked my car up from the garage.. Check valve and valve solenoid both broken. €600 later :/ and everything works perfectly.

              Comment


              • #8
                Thanks for all the help

                Comment

                Working...
                X