Announcement

Collapse
No announcement yet.

2002 Cavalier Power Loss/RPM weirdness problem solved!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CNGfamily
    replied
    Re: 2002 Cavalier Power Loss/RPM weirdness problem solved!!

    Originally posted by tpaskett View Post
    ...The check engine light came on so we hooked up the Tech2 to read the code and it was P0134 saying the O2 sensor was acting up. It was a $80 part so we tried it. ...
    It reads like you didn't initally have the "check engine" light on, but had performance issues anyway. Had you checked the OBD II codes before the light came on?, Was the light on the whole time you had the issues?

    I tend to check engine codes even if the "check engine" light is not on... it can help to chase down problems that are intermittent

    Leave a comment:


  • 2002 Cavalier Power Loss/RPM weirdness problem solved!!

    Ok I bought my 2002 Cav from the State of Utah surplus. At first everything ran great. Then after a couple weeks I had a weird issues where it did not seem to want to go over 2000 RPM. You would start going and it would cut out and sometimes stall. I could also smell CNG through the AC vents . I read some posts on here and replaced the Low Pressure Lockoff and rebuilt the Low Pressure Regulator. The CNG smell went away and the car ran again. It did not seem like it was running like it should though. There was a hesitation when starting from idle, and seemed to have low power between 2000-3000 RPM. Also it would rarely get above 3000 RPM when accelerating and would shift hard. It was a gutless wonder, especially with the AC going. So after reading more posts it looked like the next part to replace would be the Gas Mas Sensor/Mixture Control Vale. Dealers quote this at $2600+. It is $1500 in gmpartdirect.com part #52369145. My Dad is a Chev mechanic, but does not work on CNG cars. The check engine light came on so we hooked up the Tech2 to read the code and it was P0134 saying the O2 sensor was acting up. It was a $80 part so we tried it. The car runs better than it ever has now. I get full power on acceleration and can pass semi's again on the freeway. It even starts up better, I don't have to do the 6 sec startup anymore. The part # for the O2 sensor is #12568234. It took 5 mins to switch out. If you have weirdness relating to RPM and power I would try switching the O2 sensor out
Working...
X